[PHP] BlackfireのHackプランで「You cannot profile apps running on deprecated PHP versions.」とメッセージが出るときの対応

ヨメレバCSS

 Hackプラン(フリープラン)でBlackfireを実行したときに「You cannot profile apps running on deprecated PHP versions.」と言われてしまったときの対応です。

スポンサーリンク
GoogleAdSence レクタングル(大)

サポート切れPHPは動かせない

 書いてあるとおりそのままですね…

 hackプランではサポート期限の切れたPHPで実行された場合は解析してくれないみたいです。

You cannot profile apps running on deprecated PHP versions

 PHPの各バージョンのサポート期限はこちら。

Supported Versions

対応1. 有料プランにする

 Blackfireのプランを見ると、有料プランなら「PHP 5.3 and higher, Python 2.7 and 3.x」と書いてあります。

 Hackプランは「Supported PHP version only, Python 2.7 and 3.x」なので、有料プランにすれば(5.3以降であれば)解析してくれるみたい。

 Premiumプランには試用期間があるみたいなので、こちらで試してみてもよいかもしれません。

対応2. PHPのバージョンアップ

 もうひとつはPHPのバージョンアップをすることです。サポート期間内のバージョンにすれば問題なく動きます。

 ただ入れ替えるにしてもすぐには難しかったり、場合によっては不可能だったりするでしょうから、その場合は有料契約するしかないかもしれません…

スポンサーリンク
GoogleAdSence レクタングル(大)