Windows10をちょっと速くしてやろうとおもったらえらい厄介なことになってしまったときの

ヨメレバCSS

 対処法。

スポンサーリンク
GoogleAdSence レクタングル(大)

どうやらSATA2で接続していたらしい

 Windows10の使い勝手とか謎のもっさり感とかに疲れてSSD書いたしLinuxブートを検討していたのですけど、そもそもメモリも多いしSSDだしなんかおかしくない? って思って調査してみたらドライブの速度が明らかにSATA2。

(SATA3だと倍以上出るっぽい)

 うちのマザボはもう10年ものな感じのGIGABYTE P55A-UD4なのですが、ちゃんとSATA3は積んでいる模様。

 SSDもSanDisk SSD Extreme PRO 480GBみたいでSATA3には対応してるはず。

 だから。

 参考にしてたサイトに「SATA2に刺してる」とか書いてあったので蓋を開けて接続先を確認してみたら確かにSATA2のほうが埋まってるじゃん (白いのがSATA3)

SATA3に刺し直してみる

 これSATA3にしたら爆速にならない? って単純に思ってケーブルをSATA3のほうに刺し直してみたらディスクの接続先が変わったためかそのままでは起動しなくてWindowsの修復を求められてしまう。

 BIOSを見るとSSDの起動優先度が最下位になっていたので、これを一番上に上げてやると解決しました。

 それで起動してからベンチしてみても速度変わらない。あとS.M.A.R.Tが取れてないのかCrytstalDiskInfoで値が取れない。なぜ…

ACHIにしてみる

 接続方式もIDEモードになっているのがいけないのかとACHIにしてみるためレジストリをいじってBIOSを変更。(やり方はこのあたり)

 うちはWindows10なので、「HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\storahci」の「ErrorControl」を「3」から「0」に、「HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storflt\StartOverride」の「0」というキーの値を「3」から「0」に変更して保存。

 起動してみると速度が速くなるどころかデバイスマネージャなどアプリが起動してこなくなって、再起動してたら「ようこそ」から先が真っ黒になりました…

 真っ黒の状態でもシステムは生きていたらしくCtrl+Alt+Delで再起動できたため、BIOSのほうでIDEモードに戻してみたりSATA2に刺し直してみたりしたけど状況変わらず。

 Shift押しながら再起動 (以前だめな感じになったときに覚えたワザです)をしてからセーフモードに入って、そこから「システムの復元」を行うことでなんとか戻ってこれました。

 「コントロールパネル > 回復 > システムの復元を開く」で、あとは指示にしたがってぽちぽち。この機能が初めて役に立った気がする。

結局元に戻った

 最終的にSATA2のIDEモードっていう最初の状態に戻りました。変更したレジストリも3に戻した。(でもStartOverrideのほうはregedit開いたらすでに3に戻っていた…もしかして変更ミスっていたのだろうか)

 ただマシンの速度は気持ち速くなった気がします。「システムの復元」でついでに余計な情報も消えたのでしょうか…

 やはりウィンドウズは再インストールってことですね!

ちなみにSSDの速度が上がったわけではなさそうです…

参考:
SSDのベンチマーク結果が悪い、速度が遅い人にチェックして欲しい設定まとめ

スポンサーリンク
GoogleAdSence レクタングル(大)